Linux Notes

From OHRRPGCE-Wiki
(Redirected from Linux)
Jump to navigation Jump to search

Download the latest GNU/Linux binaries from Downloads. Most users will want to download the x86_64 package. Currently, if you want to run the OHRRPGCE on an ARM/ARM64 machine you will have to compile it yourself.

The OHRRPGCE does not need to be installed in "system wide" location like /usr/local/games. If you download a .tar.gz file, you can extract it anywhere, and it won't interfere with other copies of the OHRRPGCE on the same computer.

Config files and temporary files will be stored in ~/.ohrrpgce/

Installing Games[edit]

Ohrrpgce-game filebrowser on linux.png

OHRRPGCE games (RPG files) are platform independent. You can download the same zip files that Windows users download from any of the game lists

  1. Unzip the game unto a folder in your home directory. (if the zip file contains a windows .exe file you can ignore or delete it)
  2. Then simply open the .rpg file with ohrrpgce-game

You can associate .rpg files with ohrrpgce-game using gnome or kde or your desktop environment of choice.

If you prefer to run from the console you can do something like:

/usr/games/ohrrpgce-game ~/ohrgames/"Tales of the New World 2"/TNW_2.rpg

Depending of course on the name of the game, and where you unzipped it.

You can also just run ohrrpgce-game with no arguments, and you will be presented with a file-browser that lets you choose which RPG file to load.

Music[edit]

The OHRRPGCE on Linux by default uses the music_sdl backend, which requires SDL_Mixer 1.2 and Timidity++ for MIDI music, so if you do not already have those packages, get them.

Actually, it does not depend on timidity. SDL_mixer uses its own statically linked timidity code. It does not actually execute the timidity binary, nor does it link dynamically to libtimidity. However, it still requires a Gravis Ultrasound-compatible (.pat) instrument patch set. SoundFont instrument sets are NOT supported, because the version of timidity used is absolutely ancient. In addition, the statically linked timidity requires a timidity.conf file to point to the instrument set, but it doesn't understand all the config options that modern timidity does. Luckily, a normal Timidity++ install with the common instrument set Freepats will work with SDL_mixer.

You may prefer to manually install timidity.tar.gz into /usr/local/lib/timidity/

There is an alternative backend to music_sdl, music_native, which uses Audiere but does not support MIDI or BAM music. Audiere plays only through OSS and does not support ALSA. If your distribution does not have OSS enabled (symptom being an error about /dev/dsp), it might still be possible to play using the aoss OSS->ALSA wrapper: "aoss ./ohrrpgce-game".

The music/sound importer in custom requires madplay and oggenc to be installed if you want to import music and sound effects in MP3 format. OGG vorbis files do not require any extra utilities, and no extra utilities are needed by game for playback.

Other Linux distributions[edit]

The x86 and x86_64 tarball builds of the OHRRPGCE have minimal requirements and should run on any Linux distribution since at least 2011 with SDL 1.2 and SDL_mixer 1.2. See Linux library requirements.

You can also compile the OHRRPGCE yourself to use SDL 2 and SDL_mixer 2 instead. SDL 2 support in Custom (the editor) is currently not complete (see Backends), but it's fine for playing games.

See Also[edit]