Getting Quickbasic

From OHRRPGCE-Wiki
Jump to navigationJump to search
This article only applies to the DOS/QuickBasic version. It is not relevant for the current Windows and Linux versions

The status of Quickbasic is a bit iffy. Microsoft does not sell it anymore, but they have not abandoned their copyright on it, so it is technically illegal to download it. Nevertheless, you will need a copy of either QuickBasic 4.5 or QuickBasic PDS 7.1 if you want to compile the source code of the OHRRPGCE. (4.5 works best. 7.1 still hase some issues)

The only component that is required is BC.EXE which is the Basic Compiler which turns .BAS files into .OBJ files.

By default, the source is set up to compile with QuickBasic 4.5 installed in C:\QB45\

If you are using QuickBasic 7.1 or if you have installed in a different directory, you will need to edit env-set.bat


DISCLAIMER: download the following at your own legal risk.

Quick Basic 4.5[edit]

If you go to qbcafe.net you can download a complete copy of QBasic 4.5. Hope this works for all of you guys.

Quick Basic 7.1[edit]

If you want a (slightly) newer version, which seems to compile better on new computers then you can either go to the above mentioned site, or head over here for a copy of QBasic 7.1.

Note: QB7.1 does not compile the OHR correctly. Binaries made with it will crash in battles, on exit, and may set your printer on fire. You have been warned.

FreeBasic[edit]

Use FreeBasic instead. Compiling in Quickbasic is not supported in any version newer than hasta-la-qb. Unless you have a very good specific reason to be using QuickBasic, you should be using FreeBasic instead.


See Also[edit]